home news shop history forum membership galleries regions calendar contact
   

Go Back   106 Rallye Register Forum > TUNING, MODIFICATIONS & UPGRADES > Engine, Exhaust & Gearbox

Engine, Exhaust & Gearbox ECU chips, decats, cam kits,

Reply
 
Thread Tools Display Modes
Old 05-05-2017, 10:49 PM   #1
Drago
REGISTERED FORUM USER - NON MEMBER
 
Join Date: Apr 2008
Location: East anglia
Posts: 13
User Gallery
Question TU5J4 oil pressures

Hi

I am having a bit of trouble with some high oil pressures and could really do with knowing what is the norm for a high comp freshly rebuilt engine. Spec below

Wossner over size high comp Pistons
Some light head work by sabre
Newman PH4 cams
ATP throttle bodies
Crank was lightened and balanced
All new shells/ seals etc
Oil pump rebuilt


Oil pressure as follow

Cold idle - approx 85psi
Warm idle - 40psi
Warm 2000rpm - 80psi
Warm 4000rpm - 90psi

Car has been sat in garage for approx 4 years but has never been open to the elements.
Engine has probably only been running for a couple of hours in total.

I am thinking maybe the pressure relief valve in the oil pump is sticking.
But was wondering of anything else I could look out for before ripping the sump off.

Car is currently running slightly rich on an older emerald map, but not sure if this will make any difference.

Thanks all in advance

Drago
Drago is offline   Reply With Quote
Old 06-05-2017, 03:51 AM   #2
welshpug
106 RALLYE REGISTER MEMBER

 
welshpug's Avatar
 
Join Date: Mar 2006
Location: cwmcarn
Posts: 4,910
User Gallery
that sounds perfect.
welshpug is offline   Reply With Quote
Old 06-05-2017, 08:11 AM   #3
Dieseldave
106 RALLYE REGISTER MEMBER

 
Dieseldave's Avatar
 
Join Date: Sep 2008
Location: Sligo,Ireland
Posts: 1,590
User Gallery
Them figures look ok but you never mentioned the main factor, oil viscosity, what are you using?
Dieseldave is offline   Reply With Quote
Old 06-05-2017, 02:55 PM   #4
Drago
REGISTERED FORUM USER - NON MEMBER
 
Join Date: Apr 2008
Location: East anglia
Posts: 13
User Gallery
Currently using millers competition 10w/40 mineral running in oil from opie oils.

Have just checked my digi dash and Max recorded oil pressure was 110psi.(although this is probably not massively accurate)
All readings from above were using a manual guage so these will be accurate.

Car is track only so has only been running static on driveway.
Will these pressures drop slightly as the engine wears in?

Next stop is getting car mapped, and didn't want to get it on the Rolling road for the engine to destroy itself

So these figures seem about right?

Cheers all
Drago is offline   Reply With Quote
Old 06-05-2017, 03:36 PM   #5
welshpug
106 RALLYE REGISTER MEMBER

 
welshpug's Avatar
 
Join Date: Mar 2006
Location: cwmcarn
Posts: 4,910
User Gallery
yes they look spot on, and hopefully dont drop.

not likely excessive oil pressure will destroy an engine other than starting to leak everywhere
welshpug is offline   Reply With Quote
Old 22-06-2017, 03:48 PM   #6
Temple
106 RALLYE REGISTER MEMBER
 
Temple's Avatar
 
Join Date: Apr 2012
Location: Leamington Spa
Posts: 269
User Gallery
My car's cold idle is about 50 PSI and the hot idle is 25 PSI using 10W40 fully synthetic
Temple is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:56 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.